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1.1. About the Illustrations 

In This Book 

1.2. Terms and 
Conventions Used In 
This Book 

1.3. Getting Software Help 

1 
A Quick Start Guide to SunPaint 

This book is your quick start guide to SunPaint. Use it as a companion to these 
books: 

o The SunPaint Tutorial 

o The SunPaint User's Guide 

If you are not familiar with SunPaint or have never used a computer-based paint­
ing program, read the SunPaint Tutorial. Refer to the SunPaint User's Guide 
when you want detailed information about a feature or function. 

If you have not yet installed SunPaint, refer to the Installation Guide for 
SunWrite, SunPaint, and SunDraw. 

A combination of SunPaint and SunDraw were used to prepare all of the illustra­
tions in this book. 

Terms that are special to SunPaint and may be new to you, are introduced in 
italic font, for example raster file. These terms are defined when they are intro­
duced. 

The Italic font may also be used to specify variables or parameters that you or the 
system will replace with an appropriate word or string of characters. 

The bold typewriter font represents commands you enter at the key­
board, exactly as shown. Typewriter font represents what the system 
prints on your workstation screen or printer, or the name of a file. 

The bold roman font is used in the text for the names of SunPaint buttons, set­
tings, menus, and menu items. 

If you should need help using this product or the accompanying documentation: 

o See the Read This First document for known problems and solutions. A 
Read This First document is supplied with every software product. Your 
system administrator or the person who installed this software should have a 
copy. 

o Look for articles in the Software Technical Bulletin. The technical contact 
person named in your service contract with Sun should have your company's 
master copy. Check the cumulative index for relevant articles. 

~\sun ~~ microsystems 
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4 SunPaint Quick Start Guide 

o If the Read This First and the Software Technical Bulletin do not help, while 
your software is under warranty or under a software service contract, you -
may get help from Sun by calling the telephone number shown in the Read 
This First. 

o You can order a support contract through your local Sun sales office. 
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2.1. How to Start SunPaint 

Starting SunPaint With an 
Open File 

2 
A Guide to Menus and Windows 

This chapter is a quick reference to SunPaint window, menu, and mouse func­
tions. 

Type the following command from a Sun View Shell Tool or Command Tool, 
then press the I Return I key. 

To start SunPaint with an open file, type the following command from a Sun­
View Shell Tool or Command Tool, then press the (Return I key. 
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8 SunPaint Quick Start Guide 

2.2. The SunPaint Window The following illustration shows the SunPaint Window as it appears when you 
start SunPaint. 

Window Mark Window Header Resize Corner 

I I 
.r 1!j SunPaint 1.0 <64Dx480> 

-

~~@]I) ~ Button Stacks 

-· Window Border 

Canvas 

Window Footer ,__ ..r 
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2.3. Mouse Actions 

c 
Press 

Drag 

Click 

Release 

Chapter 2 - A Guide to Menus and Windows 9 

The following illustration shows all of the mouse actions you use for the LEFT 
and RIGHT mouse buttons. The MIDDLE mouse button is not used in SunPaint. 

Click LEFT Double Click LEFT Press LEFT Drag LEFT 

Press RIGHT Drag RIGHT Release RIGHT 

Press and hold the mouse button without moving the mouse. 

Press and hold the mouse button while you move the mouse. 

Quickly tap and release the mouse button once or twice. 

Release the mouse button you are pressing or dragging. 

Release LEFT 

~\sun ~ microsystems 
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10 SunPaint Quick Start Guide 

2.4. How to Display and 
Choose From a Menu 

2.5. How to Pin Up a Menu 

1. Point to the Button Stack or Abbreviated Button Stack 

2. Press RIGHT to display the menu 

3. Drag RIGHT to choose a button 

4. Drag RIGHT to choose from the displayed menu 

5. Release RIGHT after you make your choice 

The Props and Mode menus are used in this example. 

0006 

&.~~9 

1. Choose the menu you want to pin up 

2. Drag RIGHT to choose the Pushpin 

3. Release RIGHT 

~\sun ~ microsystems 
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2.6. How to Choose From a 
Pop-up Window 

2.7. How to Use a Pop-up 
Window Menu 

(Locate Owner) 

Chapter 2 - A Guide to Menus and Windows 11 

1. Click LEFT on settings 

2. Type new information in text entry fields 

3. Drag RIGHT on Button Stacks to display menus 

The Text Properties window is used in this example. 

~ SunPaint: Text Properties 

T efaces: O Lu<:ida 

.__-++-......... ........_............, ....... o 10 
~ 

Adjustment: Left .._ __ .... 
Right 

···"C·e·n·f·9··r:·9··a .. ···· -----~_... 

1. Press RIGHT anywhere on the Window border to display the menu 

2. Drag RIGHT to highlight the button you want to use 

3. Release RIGHT 

The commands on the Pop-up Window menu are: 

o Dismiss: Choose this command to dismiss the window. 

100 

o Back: Choose this command to move the window behind other windows. 

o Locate Owner: Choose this command to move the SunPaint Window to the 
front. 

~\sun ~ microsystems 
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12 SunPaint Quick Start Guide 

2.8. How to Use the 
SunPaint Window 
Menu 

((Close 

(Full Size 

)J 

) 

(sack ) 
(~~-ef-r-es-h-~) 

(Quit ) 

2.9. How to Change a 
Menu Default 

2.10. How to Choose a 
Menu Default 

2.11. How to Move a 
Window 

1. Press RIGHT anywhere on the SunPaint Window border to display the menu 

2. Drag RIGHT to highlight the button you want to use 

3. Release RIGHT 

The available commands on the SunPaint Window menu are: 

o Close: Use this command to close the SunPaint Window to an Icon. 

o Full Size: Use this command to expand the SunPaint Window to the full 
Page size. 

o Back: Use this command to move the SunPaint Window behind other win-
dows. 

o Refresh: Use this command to refresh the SunPaint Window display. 

o Quit: Use this command to quit SunPaint. 

Note that the Properties command button is grayed. This is because properties 
are not available for the SunPaint window. 

1. Point to the Button Stack 

2. Press the I Control ] key and Drag RIGHT simultaneously 

3. Choose the putton you want to use for the menu default 

4. Release RIGHT 

1. Click LEFf on the Button Stack or Abbreviated Button Stack 

1. Point to any location on the Window border 

=:11 2. Drag LEFf. Move the mouse to drag the window to the new location. 

3. Release LEFf. 

2.12. How to Move a 
Window Back 

1. Point to any location on the Window border 

2. Drag RIGHT to display the Window menu 

3. Choose Back 

4. Release RIGHT 

Alternatively, you can press the [Front LS] key. 

~\sun ~ microsystems 
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2.13. How to Move a 
Window Front 

2.14. How to Resize the 
SunPaint Window 

2.15. How to Close 
SunPaint 

Chapter 2 - A Guide to Menus and Windows 13 

1. Point to any location on the exposed Window border 

2. Click LEFT 

Alternatively, you can press the I Front LS I key. 

1. Point to a Resize comer 

2. Drag LEFT. Move the mouse to increase or decrease the window size 

3. Release LEFf 

1. Point to the Window Mark on the Window header 

~"- 2. Click LEFT 

( File )J 

2.16. How to Move the 
SunPaint Icon 

rGl 
sunP.aint 

.... 

2.17. How to Open 
SunPaint From the 
Icon 

rm 
sunP.aint 

2.18. How to Quit SunPaint 

1. Point to the SunPaint icon 

2. Drag LEFT to move the icon to the new location 

3. Release LEFT 

1. Point to the SunPaint icon 

2. Click LEFT 

1. Point to any location on the window border 

2. Drag RIGHT to display the Window menu 

3. Choose Quit 

4. Release RIGHT 

~\sun ,~ microsystems 
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3 
Painting Techniques 

The SunPaint Modes menu provides the following types of painting modes. 

o Freehand: Use this mode to paint free-form figures. 

o Geometric Modes: Use the geometric modes to draw lines, rectangles, cir­
cles, and other geometric figures. 

o Type: Use Type mode to type text on the Canvas. 

In this illustration, painting modes are surrounded by a black border. 

~ SunPaint: ModesJ9 

Painting Modes 

Fi 11 Erase Regions 
Mode Mode Modes 

You use a two-point or three-point painting technique depending on the mode 
you have chosen. 

~\sun ,~ microsystems 
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18 SunPaint Quick Start Guide 

3.1. Painting Two-Point 
Figures 

How to Paint a Two-Point 
Figure 

The following modes are called two-point figures because you specify two points 
when you paint them-the starting point and the ending point. 

Two-point figures: Line, Rectangle, Circle, Freehand, Round Rectangle, 
Polygon 

1. Choose a painting mode from the Modes menu 

2. Point to a starting position on the Canvas 

3. Drag LEFf to paint the figure 

4. Release LEFf at the ending position 

100 000 
Drag LEFT Move House Release LEFT 
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3.2. Painting Three-Point 
Figures 

How to Paint a Three-Point 
Figure 

Chapter 3 - Painting Techniques 19 

The following modes are called three-point figures because you specify three 
points when you paint them-the starting point, an intermediate point, and the 
ending point. 

Three-point figures: Arc, Curve, Parallelogram, Triangle 

1. Choose a painting mode from the Modes menu 

2. Point to a starting position on the Canvas 

3. Drag LEFT to paint from point one to point two 

4. Release LEFT 

5. Move the pointer to define the arc, curve, parallelogram, or triangle. This is 
point three. 

6. Click LEFT on the ending position 

000 
Drag LEFT Move Mouse Release LEFT 

100 
Move House Click LEFT 

~\sun ~ microsystems 
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20 SunPaint Quick Start Guide 

3.3. Using Fill and Repeat 
Options 

Painting and Filling 

Painting and Repeating 

You can paint filled or repeated shapes by choosing the Fill or Repeat Option 
from the Props menu. You can use the Fill and Repeat options separately or 
together. The Fill option uses the current pattern on the Patterns menu. 

The Circle mode is used as an example in this illustration. 

To fill a shape as you paint it: 

1. Choose Circle from the Modes menu 

2. Choose Fill from the PaintBox window 

3. Paint the circle 

Options: I Repeat 

I Fill 

I Extra 

Choose Fill 
from the 
PaintBox Window 

~00 G)'OOO 
CJ -;- CJ 

'-------__,, 

Drag LEFT Move Mouse Release LEFT Result 

The Circle mode is used as an example in this illustration. 

To repeat a shape as you paint it: 

1. Choose Circle from the Modes menu 

2. Choose Repeat from the PaintBox window 

3. Paint the circle 

4. Continue to move the mouse to paint repeated circles 

Note that the amount of space between the repeated circles depends on the rate at 
which you move the mouse. 

I Extra 

Choose Repeat 
from the 
PaintBox Window Drag LEFT Move Mouse Release LEFT Result 
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4.1. Again 

4.2. Undo 

4.3. Clear 

c 

4 
Repeating and Correcting 

You choose the repeating and correcting functions Again, Undo, and Clear 
from the Edit menu. 

~ EditJ9 

(Again ) 
(Undo 

(copy ) 
(Paste 

(Cut ) 

(Clear ) 
(Regions )J 

Choose Again from the Edit menu to repeat your last action. The action can be 
a menu choice or a painting action. 

Choose Undo from the Edit menu to undo your last action. There is one undo 
level. 

Choose Clear from the Edit menu to clear the entire Canvas. If you accidentally 
choose Clear, immediately choose Undo to restore the Canvas. 

~\sun ~ microsystems 
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24 SunPaint Quick Start Guide 

4.4. Erase You choose the Erase mode from the Modes menu. 

~ SunPaint: Modes.@ 

To use Erase 

1. Choose Erase from the Modes menu 

2. Drag LEFf, scrubbing the erase over the image you want to erase 

3. Release LEFf when you are through erasing 

The Erase mode automatically uses the white pattern. You can erase with other 
patterns (including black) by choosing a large brush, the appropriate pattern, and -) 

Freehand mode. _ 

~~sun ~ microsystems 
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5 
Using Regions to Change Images 

You use Region modes to define an area on the Canvas. Once the region is 
defined, you can do the following: 

o Copy the region to another part of your canvas. 

o Move the region to another part of your canvas. 

o Nudge the region pixel-by-pixel in one of four directions. 

o Rotate the region. 

o Flip the region end-to-end or top-to-bottom. 

o l?vert the colors of the region. 

The following region functions apply only to boxed regions. 

o Resize the region to a larger or smaller size. 

o Use the Edit menu to Cut, Copy, and Paste the region to and from the Clip-
board. 

o Save the region to a file and open a file as a region. 

You choose Region modes from the Modes menu. There are two types of 
regions, boxed andfreeform. 

~ SunPaint: ModesS ~ SunPaint: ModesS 

Boxed Regions Freeform Regions 
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28 SunPaint Quick Start Guide 

5.1. Defining Regions 

Boxed Regions 

Freeform Regions 

You can define a boxed or freeform region. 

To define a boxed region: 

1. Choose Boxed Region mode from the Modes menu. 

2. Move the pointer to any comer of the area you want to define as a region. 

3. Drag LEFf to the opposite comer, then release LEFT. 

In this illustration, a boxed region is defined around the circle. 

You use the Freeform region mode specifically for defining irregular regions. 

To define a Freeform region: 

1. Choose Freeform Region from the Modes menu. 

2. Drag LEFf and trace around any irregular shape on the canvas. 

3. Release LEFf when you have completed the tracing. The region you have 
defined is indicated by a gray pattern. 

In this illustration, a freeform has been traced around the circle to define the 
region. 

~~sun ~~ microsystems 
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5.2. Moving and Copying 
Regions 

Drag-Move a Region 

Drag: I Move I Co PY I 
I Transparent I 

Drag-Copy a Region 

Dt·ag: I Move I Co PY I 
I Transparent I 

/ 

Chapter 5 - Using Regions to Change Images 29 

You can move or copy both Boxed Regions and Freeform Regions. The pro­
cedure is the same for both region types. 

When you move a region, the original image is replaced by white space when 
you drag it to another location. To move a region: 

1. Choose Move from the PaintBox Options window. 

2. Point anywhere inside the defined region. 

3. Drag LEFT to move the region. 

The pointer changes to the Move pointer. 

4. Release LEFT when the region is where you want it. 

To ''un-define'' a region, you can Click LEFT anywhere outside the defined 
region; define another region; or choose a different mode. 

D1 __.Move Pointer 

When you copy a region, the original image remains unchanged as you drag a 
copy of the region to another location. 

1. Choose Copy from the PaintBox Options window pane. 

2. Point anywhere inside the defined region. 

3. Drag LEFT to copy the region. 

The pointer changes to the Copy pointer. 

4. Release LEFT when the region is where you want it. 

~\sun ~fllfli microsystems 
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30 SunPaint Quick Start Guide 

Transparent On 

Drag: l Move I Co PY 

I Transparent 

To ''un-define'' a region, you can Click LEFf anywhere outside the defined 
region; define another region; or choose a different mode. 

Pointer 

When the Transparent setting is on, only the black pixels in the image are 
moved with the region. White pixels in the region are transparent and do not 
mask the image where the region is moved. 

In this illustration, a region has been transparently copied from an area of the 
canvas with a white background to an area that is covered with a pattern. Note 
how the pattern shows through areas of the region that are not entirely black. 

Revision A of 14 November 1988 
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Transparent Off 

5.3. Nudging, Rotating and 
Flipping Regions 

Chapter 5 - Using Regions to Change Images 31 

When the Transparent setting is off, the region is opaque. All of the white and 
black pixels within the boxed boundary are moved. This illustration shows the 
same copy procedure as the previous illustration. However, the Transparent 
setting is turned off. Notice that the pattern is partially covered by the region. 

You can nudge, rotate, flip, or invert both Boxed Regions and Freeform 
Regions. The procedure is the same for both region types. You choose these 
functions from the Regions menu. You choose the Regions menu from the Edit 
menu. 

CD 
CD 
(8 
~ 

CID 
CID 
( ~) 

QD 
(~) 
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32 SunPaint Quick Start Guide 

Nudge 

Rotate (counterclockwise) 

You can nudge a region pixel-by-pixel in one of four directions. The direction 
are up, down, right, and left. To nudge a region, define the region, then choose a 
direction from the Regions menu. To nudge diagonally, move up, then right or 
left; or down, then right or left. 

Each time you choose the Rotate (counterclockwise), the region is rotated 90 
degrees counterclockwise. You choose Rotate from the Regions menu. 

~\sun ~~ microsystems 
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Rotate (clockwise) 

Flip (Right-to-Left) 

Chapter 5 - Using Regions to Change Images 33 

Each time you choose the Rotate (clockwise), the region is rotated 90 degrees 
clockwise. You choose Rotate from the Regions menu. 

To flip a region around its vertical axis, choose Flip (Right-to-Left) from the 
Regions menu. 

4}\sun 
~ microsystems 
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Flip (Top-to-Bottom) 

When a region is flipped, a copy is made of the region, it is flipped over, then laid 
on top of the original region. Therefore, if the Transparent setting is on, flipping 
a region results in both images being visible. If you get this effect by mistake, 
undo the flip operation, tum off the Transparent setting, and flip the region again. 

To flip a region around its horizontal axis, choose Flip (Top-to-Bottom) from 
the Regions menu. 

Revision A of 14 November 1988 
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Invert 

Transparent Inversion 

Chapter 5 - Using Regions to Change Images 35 

The Invert function changes all black pixels in the region to white, and all the 
white pixels to black. To invert a region, choose Invert from the Regions menu . 

• • 

When you invert a framed region with the Transparent Option on, the resulting 
region is entirely black. This is because all the white pixels are transparent, 
allowing the black pixels from both the original and inverted regions to show. 

~\sun ~ microsystems 
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5.4. Resizing Regions You can resize boxed regions. Freeform regions cannot be resized. 

You can enlarge or reduce a region proportionally or non-proportionally. You 
use the comer region handles to resize proportionally, and the side handles to 
resize non-proportionally. 

To resize a region proportionally in width and height 

1. Point to a comer handle. In the illustration below, the pointer is in the right 
comer handle. 

2. Drag LEFT to enlarge or reduce the region. The illustration shows the region 
being enlarged. 

3. Release LEFT. 

To resize a region non-proportionally: 

1. Point to a side handle. 

2. Drag LEFT to enlarge or reduce the region. The illustration shows the region 
being enlarged horizontally. 

3. Release LEFT. 

4}~sun 
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6 
Clipboard Functions 

You choose the Clipboard functions Copy, Paste, and Cut from the Edit menu. 
The Clipboard functions Copy and Cut become available when a region is 
defined on the Canvas. 

~ Edit J9 

(Again 

(Undo 

(copy ) 

(Paste ) 
(Cut ) 

(Clear ) 
(Regions )J 

The Clipboard is a temporary storage location for raster images. It is shared by 
SunPaint, SunDraw, and Sun Write. You can cut or copy a region from SunPaint 
and paste it into SunDraw or Sun Write. You can also cut or copy objects from 
SunDraw and paste them into SunPaint or Sun Write. Of course, you can always 
cut, copy and paste within SunPaint. 
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6.1. Copy 

6.2. Paste 

6.3. Cut 

When you choose Copy, a defined region is copied from the Canvas to the Clip­
board. The image is then in two places-the Canvas and the Oipboard. 

When you choose Paste, the last image that was cut or copied to the Clipboard is 
displayed in the center of the Canvas. You can move the region to a different 
location if you wish. 

When you choose Cut, the defined region is moved from the Canvas to the Clip­
board. 
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Resizing the SunPaint Canvas 

To change the size of the canvas: 

1. Choose Canvas from the View menu 

SunPaint: Canvas View 

~ SunPaint 1.0 

2. Canvas Width: The Canvas width is shown in pixels. Click LEFT on the up 
or down arrow until you reach the desired width. You can Press LEFT on the 
arrow to rapidly change the number. 

Alternatively, you can backspace to erase the current number, then type the 
new number. 
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Using Scrollbars 

3. Canvas Height: The Canvas height is shown in pixels. Oick LEFT on the 
up or down arrow until you reach the desired height. You can Press LEFT on 
the arrow to rapidly change the number. 

Alternatively, you can backspace to erase the current number, then type the 
new number. 

4. Choose Apply from the Ok menu. The Canvas is changed to the size you 
specified. 

If you have set Apply as the default on the Ok menu, you can Click LEFT on 
Ok to apply the changes. 

~ Sun Paint: Canvas View o-t:D 
Canvas Width Canvas Height (~ 
~ ??..9. ....... ~~?..?. ... . ... 

----- __r 

~ ~-___.... 

Type to change 

Click LEFT to change-~ 100 Click LEFT to apply-(~ 

CJ 
' ,. 

When you resize your Canvas, the SunPaint Window is changed to accommodate 
the new Canvas size. When you resize the SunPaint Window the Canvas size is 
not affected. 

You cannot make the SunPaint Window larger than your current Canvas size. 
You can, however, make it smaller than your current Canvas size. 

When you make your SunPaint Window smaller than your Canvas, scrollbars 
appear on the window. You use the scrollbars to scroll the Canvas under the 
window. 
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SunPaint 1.0 

Chapter 7 - Resizing the SunPaint Canvas 45 

This illustration shows a window without, and with scrollbars. The SunPaint 
Window on the left is the same size as the Canvas. The entire Canvas can be 
seen through the window. The SunPaint Window on the right is smaller than the 

Canvas. You can only see a portion of the entire Canvas. 

<450:i.i:300> Sun Paint 1.0 <450:i.i:300> 

( File JJ ( View )J ( Edit JJ ( Props JJ ( File JJ ( View JJ ( Edit )J ( Props JJ 

111111111111111111111111111111111111 

To use the scrollbars: 

o Click LEFf on the arrows to scroll the canvas up, down, right, or left one 
screen pixel at a time. 

o Drag LEFT in the drag area to continuously scroll the canvas. 

o Click LEFf on the cable anchors to jump from left to right or top to bottom 

of the canvas. 

c:::i---Top Cable Anchor 
Up Arrow 
Drag Area 
Down Arrow 

~Proportion Indicator r Cable 

c::::J Bottom Cable Anchor 
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Panning the Canvas In addition to using scrollbars, you can pan the Canvas under the SunPaint Win­
dow. When you pan, you move the Canvas smoothly around in any direction. 

To pan the Canvas: 

1. Press and Hold the I Control I key. 

2. Point to any area of the visible Canvas 

3. Drag LEFT in any direction to pan the Canvas. 

Note that the pointer changes to the Panning Pointer. You must hold the 
! Control I key and Drag LEFf simultaneously. 

4. Release the key and the button when you are finished panning. 

<450K300> 

--=====-) ( View ) ( Edit ) ( Props) 

Panning Pointer 
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8.1. Opening Pictures and 
Regions 

About Paint and File Types 

Picture 

Region 

8 
Opening and Saving Pictures and 

Regions 

To open a file as a Picture or Region: 

1. Pop up the Open I Save window. 

2. 

3. 

4. 

~ SunP'aint: Open I Save 

Paint type: I Picture I Region I 
File type: I Raster I lco n I 

Directory: /home/server/username ...................................................................................... -............................... . 

File: !J.1.~.~.~.~.~ ......................................................................................... .. 

~ ~ 

Click LEFT on Picture or Region to choose the Paint type. 

Click LEFT on Raster or Icon to choose the File Type. 

Change the Directory pathname if necessary. 

5. Enter the file name you want to open on the File line. 

6. Click LEFT on Open 

You can open a file as a Picture or a Region. 

When you open a Picture the Canvas is resized to fit the picture size. The name 
of the Picture file is displayed in the SunPaint Window Header. The file name 
changes whenever you open a new Picture. 

When you open a Region it is displayed in the center of the Canvas. It is defined 
as a Move region so you can relocate it. Drag LEFT on the region to move it. 

~\sun ~~ microsystems 
49 Revision A of 14 November 1988 



50 SunPaint Quick Start Guide 

Raster File 

Icon File 

8.2. Saving A Picture or 
Region 

Naming SunPaint Files 

Raster files can be used by Sun Write, SunDraw, raster-oriented programs, or 
applications that accept raster files. SunPaint raster files contain the mapping of 
all white pixels and all black pixels as they appear on the screen. 

Icon files are in Sun View icon format. The Icon format is used to create icons, 
pointer symbols, and panel features for Sun View programs. 

The Sun View 1 Beginner's Guide describes the Sun View Icon Editor. The Sun­
View 1 Programmer's Guide describes the icon format and the ways that you can 
use icons. 

When you save a Picture the entire Canvas is saved, regardless of the size of the 
image on the Canvas. 

When you save a Region, you define a portion of the Canvas as a region, then 
save that region. 

To save a Picture or Region: 

1. Choose Open I Save from the File menu. 

2. Choose Picture or Region 

3. Choose Raster or Icon 

4. Change the Directory pathname if necessary. 

5. Enter the file name you want to use. 

6. Click LEFT on Save. 

To help you or someone else identify the files you create with SunPaint, you 
should consider adopting the following file naming conventions: 

o Name Raster files: filename. raster or filename. rs 

o Name Icon files: filename. icon or filename. ic 

You can use the following characters as part of a SunPaint file name: 

a-z, A-Z, 0-9, I 

If you try to save a file with a name that includes characters other than the ones 
listed above the error message ''Unallowable file name'' appears. Enter a new 
file name, using only allowable characters. 
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Printing Pictures 

There are three ways to print the picture currently displayed on the Canvas: 

o Choose Print Picture from the Print menu. You display the Print menu 

from the File menu. 

IJJ 

((Open I Saye ~)) I (·· JJ 
l Screen Cap ((Print Picture )) 

(Printer Settings 1*) 

o Choose Printer Settings from the File menu to pop up the Printer Settings 

window. Make any necessary changes to the settings. Click LEFf on the 

Print command button at the bottom of the window. 

~\sun ~~ microsystems 

SunPaint: Printer Settings o-f::D 

Destination: I Printer I File I 
Printer Name: .1.~ .......................................................................................................................... . 

Orientation: I Upright I Sideways I 
Position: 0.25 inches from left 

0.25 inches from bottom 

Appearance: I Scale I Size I to: ~..... inches 

I Single Bits I Double Bits I 
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o If you have set Print Picture as the Print menu default, and have also set 
Print as the File menu default, you can Click LEFT on the File Button Stack 
to print your picture. 

Refer to the SunPaint User's Guide for detailed information about printing and 
the Printer Settings window. 
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