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CONTACT INFORMATION

Home Theater Master and Universal Remote Control, Inc., are dedicated to putting customer requirements
first. With the introduction of the HTM MX-1000 , the MX Operating Program software, and the MX
Designer software, our entire team has worked diligently to provide one of the most sophisticated home
entertainment accessories available.

We will continue to improve and upgrade the MX Designer software. With that in mind, we’d like you to know that we
look forward to your comments and questions. You can contact us via the following:

Universal Remote Control, Inc.
500 Mamaroneck Avenue,
Harrison, NY.  10528

Website: www.hometheatermaster.com

Customer service e-mail: service@urcmx.com

Customer service hours are 9:00 a.m. to 6 p.m. EST, Monday-Friday.

Information contained herein ©2001 Universal Remote Control Inc.
Software v 2.25.  April 2001.

Document v 2.25.2
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INTRODUCTION

MX Designer is a powerful addition to the MX-1000 preprogrammed/learning universal remote
control from Home Theater Master. It allows you to quickly and easily refine the capabilities of your
remote by customizing Device screens, or pages. Using a PC and a serial cable connected to your
remote, you can download new button and page designs to your remote and upload previously-
created page definitions for storage and manipulation. You can even import command sets from
earlier versions of the MX Operating Program.

NOTE: A tiny MX-1000 in the margin is used throughout this guide to indicate
important information.

QUICK START: USING DESIGNER RIGHT AWAY

A companion to this Guide is the Quick Start booklet. Refer to it now if you want to cut to the
basics of file transfer and button design.

MX DESIGNER OVERVIEW

 Change existing buttons, Draw new buttons: see page 20.

 Redesign Device Page layouts: see page 19.

 Drag old and new buttons onto Device Pages: see page 19.

 Import Files from previous versions: see page 10.

 Save buttons for future use: see page 17.

 Archive multiple Workspaces for different requirements: see page 14.

 Upload and Download new Device button designs to the MX-1000: see page 7.
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Covered in this chapter:

•  Why software?

•  What MX Designer can do

WHY SOFTWARE?

Why would you want to use software to program your remote, when you already know that the MX-
1000 itself is quite capable of creating and assigning buttons for all your Devices? Simple: the
software can do much more, and it does it faster.

On the other hand, if you don’t feel inclined to create master works of art for your buttons, or you’re
not comfortable with PC software, you can bypass Designer altogether and still enjoy a rich,
complete experience setting up the MX-1000 directly from the remote. The choice is yours: however,
may we suggest that the possibilities for creativity using MX Designer can provide some pretty
interesting results… .

Take a look at the figure below, which compares an actual MX-1000 screen with the MX Designer
display screen. You can see that the software duplicates the remote’s main display area. This is one of
the design details that makes using the MXOP so simple.

NOTE: You can see a difference in the typeface shown on the remote’s screen
compared to the MX Designer ‘s screen. When designing or editing
buttons, careful centering of text on buttons will ensure proper placement
of labels following downloading to the remote.

MX-1000 Main Screen MX Designer Main Screen
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MX DESIGNER FEATURES

Of course, you still need the remote for some programming functions. Here’s a basic list of what you
can expect the software to do for you.

WHAT MX DESIGNER CAN DO:

•  Change, delete, add, and copy buttons, to a total of 50 designs (each of which can be used
many times on different page displays).

•  Add new buttons from the preset library; drag buttons from the library to Device pages.

•  Drag ‘n’ drop buttons to new positions.

•  Change button labels, using two sizes of text at once, if desired.

•  Design new buttons with built-in drawing tools.

•  Zoom in to individual-pixel level for exact drawing.

•  Position buttons precisely with grid control.

•  Create and store extra buttons for future use.

•  Upload settings from the MX-1000, which can then be changed.

•  Maintain macros and punch throughs during the data transfer process.

•  Save uploaded page formats to disk.

•  Download new and revised page and button designs to the MX-1000.

•  Import command sets from the MXOP software.

•  Import page and button designs (command sets) from files created by other users.

•  Provide speedy operation through extensive use of mouse right-click.

WHAT MX DESIGNER CANNOT DO (YET)

•  Add preprogrammed commands to buttons.

•  Delete blank or unused pages.
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HOOKING UP THE HARDWARE

The MX Designer program can transfer Device data to and from the MX-1000 remote control.

Covered in this chapter:

•  Connecting the serial cable

•  Serial Port Settings

Transferring data is accomplished with the special cable provided with the MX-1000.

CONNECTING THE SERIAL CABLE

One end of the cable is a mini-jack that plugs into your MX-1000; the other end is an RS-232 serial
connector that goes to a PC serial port.

Remote to PC Connector Cable
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To connect your MX-1000 to your PC:

1. Ensure that you have a spare, active serial port on your PC. You may have to change a
setting in your BIOS.

2. Plug the female serial connector to a serial port on your PC.

3. Plug the mini-jack into the MX-1000’s base.

NOTE:  Prior to downloading any new settings to your remote, it is a good idea to
upload your current settings and save them. This way, you will always have
a backup in case an operation fails, especially if you have already spent
some time programming your remote.

To upload and download data, refer to Chapter  2, Transferring Data.

Buttons you design are easily transferred to your MX-1000 remote control. Storing layouts that
you’ve created and taught on your MX-1000 can be uploaded to your PC for storage and
manipulation. See Chapter 2 for simple instructions on hooking up your remote to your PC.

SERIAL PORT SETTINGS

Data transfer via serial ports can sometimes be tricky. To set up the software for a port on your PC:

1. Click Tools > Settings.

2. Click to select a serial port that you know is available. Com 1 is recommended.

If a particular port is not is in use or not
activated, you will have to do some
troubleshooting, either to set up your BIOS
or remove Com port conflicts.

3. Check to ensure that your PC’s port settings conform to the following:

PARAMETER SETTING

Bits per second: 115200
Data bits: 8
Parity: None
Stop bits: 1
Flow control: Xon / Xoff

Before you can transfer data between the Designer software and the MX-1000 remote control, you
must connect the serial cable between your PC and the remote.

You can also import and use command sets created with the MX Operating Program (see  Importing
Command Sets from MXOP on page 10) as well as use other Designer files (see Error! ReferenceError! ReferenceError! ReferenceError! Reference
source not found.source not found.source not found.source not found. on page Error! Bookmark not defined.Error! Bookmark not defined.Error! Bookmark not defined.Error! Bookmark not defined.).
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TRANSFERRING FILES AND DATA

Operating data and button information stored in your MX-1000 remote control can be saved to disk
using the MX Designer software. New files created using MX Designer can be transferred to the
remote as well. And, you can use .mx Workspace files and data created by others.

Older data files created using the MX Operating Program can be converted for use in MX Designer;
refer to Chapter 4 for details.

Covered in this chapter:

•  Workspace files and data types

•  Transferring Files:

 Uploading Files from MX-1000 remote to MX Designer

 Downloading Files from MX Designer to MX-1000 remote

WORKSPACE FILE AND DATA TYPES

All button design and edit work is done within the Designer Workspace. (Learn more about the
Workspace in Chapter 7). The key resource tool for the Workspace is a single  .MX file format.

The program and command-code content held in the MX-1000 can be sent to Designer, and saved
as a Workspace file. This action creates a transferable .mx master file. This file is highly portable:
anyone with Designer can use it to reprogram their own MX-1000. And, for peace of mind, your own
designs and programming can be backed up or archived for later retrieval.

Workspace files include the following information:

•  button images

•  button placement on all Device pages

•  command codes associated with each button

•  macros created on the MX-1000

•  punch through information created on the MX-1000
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TRANSFERRING DATA

Buttons you design are easily transferred to your MX-1000 remote control. Layouts that you’ve
created and taught on your MX-1000 can be uploaded to your PC for storage and manipulation. (See
Chapter 2 for simple instructions on hooking up your remote to your PC.)

UPLOADING

Begin by uploading your current MX-1000 settings to the program. This will allow you to save a
backup of your remote’s commands, which you can always reinstall if you make a mistake or change
your mind.

The MX Designer Workspace is comprised of two types of data:

•  Operating Program dataOperating Program dataOperating Program dataOperating Program data: includes description, design, labels, macros, punch throughs,  and
placement of buttons.

•  Learned Program data: Learned Program data: Learned Program data: Learned Program data: includes Device codes and learned commands for individual buttons.

To upload Workspace data from your MX-1000:

4. Ensure that you have correctly connected your PC and remote using the supplied cable; see
Chapter 2.

On your MX-1000, select Program Loading from the System Setting screen. The PC Interface
screen displays.

5. From the software menu, click Tools > Upload or the Upload icon on the button bar.

6. Click Save as new file for the operating system in the dialog box.

7. Press the Up Load button under Operating Program on the
remote’s PC Interface screen. The software takes control
and transfers the data from your remote to the PC; a progress
bar displays, indicating that the transfer is active.

The progress bar text reports Done upon successful completion.
Click OK to save the Workspace file; you can give it a new name or
save it as an existing .mx file.
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8. To upload Learned Data, repeat Step 5, but click Update the learned functions to current file.

9. Press the Up Load button under Learned Program on the remote’s
PC Interface screen. The software takes control and transfers the
data from your remote to the PC; a progress bar displays,
indicating that the transfer is active.

10. The progress bar text reports Done upon successful completion. Click OK.

NOTE:  The uploaded data is automatically integrated with the open Workspace file.

11. Begin designing your new Workspace. See Drawing buttons on page 20 for details.

DOWNLOADING

Once you have created a new command set for your MX-1000 using MX Designer (or if you simply
want to reinstall an earlier setup), you can easily transfer Workspace data to your remote. The
procedure is basically the opposite of Uploading.

Both types of Workspace data can be transferred to the remote:

•  Operating Program dataOperating Program dataOperating Program dataOperating Program data: includes description, design, labels, macros, punch throughs,  and
placement of buttons.

•  Learned Program data: Learned Program data: Learned Program data: Learned Program data: includes Device codes and learned commands for
individual buttons.

To download the Operating Program to your MX-1000:

12. Ensure that you have correctly connected your PC and remote using the supplied cable; see
Chapter 2.

On your MX-1000, select Program Loading from the remote’s System Setting screen. The PC
Interface screen displays.

13. From the software menu, click Tools > Download. A dialog box opens, confirming your
request with instructions on proceeding.

14. Click Operating Program > Download on the remote’s Program
Loading menu screen. Do not click Download under the  Learned
Program heading on the MX-1000.

The software takes control and transfers the data from your PC to the
remote; a progress bar displays, indicating that the transfer is active.
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The remote emits a beep when the process is complete. The dialog changes to a message
indicating completion; the remote displays a test screen, indicating all systems are good.

15. Click Close when the process is complete.

To download the Learned Program data to your MX-1000:

16. Ensure that you have correctly connected your PC and remote using the supplied cable; see
Chapter 2.

On your MX-1000, select Program Loading from the System Setting screen. The PC Interface
screen displays.

17. From the software menu, click Tools > Download.
A message window opens, confirming your request with instructions on proceeding.

18. Click Learned Program > Download on the PC Interface Screen of
the MX-1000. Do not click Download under the Operating Program
heading on the MX-1000.

19. Click Download in the message window shown in Step 4444. The
software takes control and transfers the data from your PC to the
remote; a progress bar displays, indicating that the transfer is active.

The remote plays a beep when the process is complete; the remote displays a test screen,
indicating all systems are good.

Click Close when the process is complete.

NOTE: There is no Learned Data in the default Workspace; you must upload your
own data first. Otherwise, you will get an error message.
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IMPORTING COMMAND SETS FROM MXOP

There is already a strong user-base of MX-1000 owners. With the special design capability of MX
Designer, there are sure to be some interesting screens created. You can share your own creations
with other users by transferring Workspace data. You can also import files created in the previous
version of MXOP.

Covered in this chapter:

•  Importing Command Sets from MXOP

IMPORTING COMMAND SETS

To import command sets created in the MX Operating Program:

Ensure that you have all file types associated with the command set you want to import: .mdl, .ldt,
.pdt and button.ini.

20. Click File > Import > MDL File.

21. Choose the .mdl file you want to import using the File browser; immediately, another
dialog box opens asking you to find and select your button.ini file.

22. Find the button.ini file associated with the .mdl file you selected, and click it to finish
the import procedure.

NOTE:  There were some instances of file corruption with older buttons; Designer
automatically repairs any problems it discovers during the import process.

A progress bar displays during import; upon completion, the program returns to the
Workspace screen.
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23. Click File > Import > PDT File. Designer asks if you want to save your newly imported
information first.

24. Enter a name for a new Workspace file and click Save.

25. Import the .pdt file associated with the .mdl file imported in Step 2.
26. Click File > Import > LDT File.

27. Import the .ldt file associated with the .mdl file imported in step 2.

28. Make any changes you like to the buttons and page layout.
29. Save the file using File > Save Workspace, or File > Save As Workspace.

30. Download the data to your MX-1000; see the section titled Downloading on page 8.

NOTE: There is no provision in MX Designer for exporting data back to previous
versions of MXOP.
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BUTTONS AND COMMAND CODES

When it comes to designing Pages for the MX-1000 remote control, it’s all about the buttons. But
before you begin designing your own screens, it’s a good idea to learn how command codes are
associated with buttons, and how you can ensure that you maintain these links during the upload and
download process.

Covered in this chapter:

•  Learned Data/Command Codes

•  How are codes linked to buttons?

LEARNED DATA/COMMAND CODES

Here are a few key things to remember about Learned Data, or Command Codes, when customizing
your Pages and buttons:

31. Commands can not be added using the software.
32. When you upload Learned Data to Designer, your command codes, macros, and punch

throughs stick with the buttons.

33. When you download Learned Data to your MX-1000 remote, codes, macros, and punch
throughs stick as well… unless you’ve moved the buttons.

HOW ARE CODES LINKED TO BUTTONS?

During the transfer process, the preprogrammed codes are uploaded and stored as a Button
Function Property. You can see the property associated with any button by right-clicking on a button,
and clicking Function Property.
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If you click on any other function in the property
sheet, a message will tell you which button the
function is assigned to, and which Device Page
the button is on. It will also inform you that any
new buttons you have drawn are currently
undefined.

BUTTON LIMITS

Even though the design interface allows buttons to be placed anywhere on the screen, there is a
design limit built in to the software. You will get an error message if you try to place more than 14
buttons on a screen.

Also:
•  A total of 56 buttons per device can be deployed: 14 per screen.

•  While it may appear that buttons can be added anywhere on a Page, note the position of the
default button command set carefully. With the exception of adding two buttons to the bottom
row of each Page, beside the Last Page button, the software actually really only remembers the
location of the existing 12 buttons. Placing buttons off this “matrix” may lead to unusual results.
Not that it cannot be done: just watch for anything out of the ordinary when you download the
command set to the MX-1000.

•  MX Designer can maintain a maximum number of 50 distinct and individual buttons per
Workspace. This is true whether the buttons are tiny or large, and is due to the memory structure
of the MX-1000. If you try to add more than 50 buttons you will get an error message. More than
50 can be saved in the Workspace by adding them to the More buttons template.

•  Of the 50 buttons that can be deployed, eight are reserved for use by the software; this means
that you can create up to 48 additional buttons per Workspace. The eight reserved buttons are
displayed on the Buttons template in angled brackets when you first open the default
Workspace, e.g.: <BW1>.
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SOFTWARE DESCRIPTION

This chapter describes the MX Designer software in detail.

Covered in this chapter:

•  MX DESIGNER Workspace

•  Menu bar

•  Toolbar

•  Device Tree & Button Template Tabs

•  Workspace Display and Navigation

MAIN MX DESIGNER WORKSPACE

The MX Designer Worskpace display is made up of several parts, as detailed in the following section.
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MENU BAR

The Menu bar is pretty straightforward, and comprises the
following items:

Figure 3

File

 Load Default Model: Loads a default, blank workspace.
 New Button: Opens a blank Draw window for new buttons.
 Open Button File: Loads a saved button *.btn file.
 Close Button File: Saves and Closes any new or edited buttons.
 Save Button File: Accessible when working with a *.btn file.
 Button Save As: Saves a *.btn file under a different name.
 Open Workspace: Loads a saved *.mx Workspace file.
 Close Workspace: Closes workspace and offers to save the file.
 Save Workspace: Saves your current work as a .mx Workspace file.
 Save As Workspace: Allows you to save the Workspace under a different name.
 Import: Opens and converts MDL, PDT, and LDT filetypes from older versions of MXOP.
 Recent files area: Lists the last few files opened.
 Exit: Quits the program, offering to save the Workspace if you haven’t already done so.

Edit
Undo (Ctrl Z): Cancels up to eight of your most recent actions, when drawing or moving buttons.

View
Toolbar: Toggles Toolbar view.
Status Bar: Toggles lower Status Bar view, indicating program resources available.
Main Page: Brings Main Page display to top.
Next page: Opens next page of Device you are currently viewing.
Previous page: Cycles through open pages.

Device
tree

Buttonbar

Page Preview
Window

Button Draw
Window

Menu bar

Workspace
Display
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Open
Upload

Tools
Upload: Sets up the process of transferring data from your MX-1000 to the PC.
DownloadDownloadDownloadDownload: Sets up the transfer of new or saved Workspace data to the remote.
SettingsSettingsSettingsSettings: Establishes which Serial port your transfer cable is connected to.

Window
CascadeCascadeCascadeCascade: Neatly stacks all open Page display windows.
TileTileTileTile: Opens all Page display windows to the same size, showing all.
CloseCloseCloseClose allallallall: Closes any windows open in the Workspace display area.

Help
Typical Help menu items are listed here, including About inforamtion.

TOOLBAR

The Workspace Toolbar offers quick access to some Menu functions, as well as some draw-specific
tools for designing buttons.

Let’s look at functions that are found on the Toolbar, and not available from menus:
 Text, background: Adds text to the background display of any Page.
 Text, label: Adds text for button labels.
 Text, large: Selects the larger of two text sizes.
 Text, small: Selects the smaller of two text sizes.
 Grid: Superimposes a grid against the Page display, for help when

positioning buttons. The grid has an auto snap-to function which is
active whether it is visible or not.

DEVICE TREE AND BUTTON TEMPLATE TABS

When you start MX Designer the first time, the Device Tree loads a
default.mx Workspace file. After that, the program remembers
which Workspace was loaded last time, and displays that
information in the Device Tree.

The left-most pane in the MX Operating Program window, referred
to as the Device Tree, displays an explorer-like tree of all the
Devices available to the MX-1000.

Visible along the top of the Tree window are three tabs: Home,
Buttons, and More Buttons.

Text,
Large

New Save

Main
Page

Previous

Next

Text,
Back-
ground Text,

Label
Text,
Small

Grid

Close
Current

Close All
Down

load Cascade

Tile
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DEVICE TREE

Using the tree is simple:

•  Double-click on any Device name; double-click
on a page number to display that page of the
Device system in the Page Preview window.

TIP: Double-clicking a Device button when the Main
Device Page  is  up opens Page 1 of the Device.

•  The Device Tree display can be widened for
iewing by click-dragging the mouse on the frame border.

BUTTON TEMPLATES

Selecting either Button Tab opens the Button Template display.

 Buttons: This template displays all buttons registered for use with Designer. Using this template, you
can save new buttons, open them into the Draw window for designing, or Move buttons to the More
buttons template.

 More buttons: Displays buttons not actively in use with the Designer program. This template is a
storage area. You can save buttons here for later use. You may, for example, have designed a few
buttons that you don’t want to employ in the program just yet, but you don’t want to lose them, either.
When you do want to use a button stored here, you simply Copy them to the Buttons template.

Detailed steps for utilizing the Buttons tabs are described below.

BUTTON TAB AND MORE BUTTONS TAB TEMPLATES

The Buttons tab template displays all buttons used in the
open Workspace. These buttons are active for designing
Page screens for your MX-1000 remote.

The More buttons tab template displays buttons not
actively used in the open Workspace, but available for use.
This is where you store extra buttons you have designed,
or buttons you’ve imported from previous iterations of the
software, for later use.

Some important functionality can be found on these
templates through right-clicking. More importantly, you
can drag buttons out of the templates and place them
right on any open Device Page.

To add a button to a device:

34. Open any Device Page from the Device tree.
35. Click the Buttons tab or More buttons tab to display

the Buttons template.

36. Click and drag a button into position on the Device Page.

NOTE:   Buttons cannot be added to the Main Device Page in this manner.
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BUTTON TEMPLATE MENUS

The Button Template Menu is accessed by right-clicking on any button. This
section describes the functions available from this menu.

Edit
Clicking the Edit menu opens the button to a Button Draw window, where you can edit it using
the Draw tools menu on the side of the display. You can also open a Draw window simply by
double-clicking on any button. For details on using Draw tools, refer to Chapter 8.

Import
Any *.btn file can be added to the Button template; up to 50 buttons in all can be used at one time.
If you need to import or create more than 50 buttons, add them to the More buttons template
instead.

To import a button:

37. Right-click anywhere on the Buttons template.
38. Click Import button file (*.btn).

39. In the Open dialog box, click the *.btn file you want; the button is added to the template.

NOTE:   The same button can be opened to the template more than once.

Export
Any *.btn file can be exported, or saved to disk.

To export a button:

40. Click the Buttons tab to display the Buttons template.

41. Right-click the button to export.

42. Click Export as button file (*.btn).

43. Save the button.

Send to “More buttons”
Send to More buttons moves the selected button to the “More buttons” template.

Delete
Clicking Delete deletes the button selected, after verifying that this is what you want to do.

Rename
Click Rename to access the button label and change the name. Also, you can click on the button title
displayed in the template; after a short pause, it becomes available for edit.

Properties
Clicking Properties allows you to rename a button’s visible label and its internal program label.
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WORKSPACE DISPLAY

The Workspace display area of MX Designer is the basic holding area for working with Device
Pages and using the Draw tools to edit buttons.

WORKSPACE NAVIGATION

Double-clicking on any Device Page in the Device
tree opens the Page in the Workspace, or  brings
that Device Page to the top of the stack.

When multiple Pages are open, use the Cascade
or Tile buttons in the Window menu, or the
buttons on the Toolbar, to help sort the display
windows.

Double-clicking on the Main Device Page opens
that Device’s Page 1 and brings it to the top of the
stack.

Use the Arrow buttons to cycle through pages in
an individual device; if they are not open, this will
open them.

BUTTON MANIPULATION

The Page Preview area of the Workspace displays the currently selected Device Page screens. Apart
from actually designing buttons, this is where most of the activity takes place. Here, you can change
buttons, change labels, and copy and move buttons around to suit your own requirements. This is
the key feature of MX Designer, and what makes it so desirable for owners of the MX-1000 universal
remote. Here’s what you can do in the Page Preview window:

•  Drag a button from either Button template to add it to any
open Device Page.

•  Right-click any button on any Page, and instantly move it to
another Page in the same device, or Delete it altogether
(when you delete a button, the label is deleted as well).

•  Right-click on any button on any Page, and discover what
command is assigned to it.

•  Turn on the Grid for guidance when positioning buttons. The
grid snap-to is always on even when it is not displayed; hold
down the Alt key to drag buttons without the snap.

•  Nudge and Fine Nudge: Use the cursor keys to nudge the
buttons in small increments. Hold down the Ctrl key at the
same time to invoke Fine Nudge, which moves a button ½
the distance of regular Nudge.

•  Double-click on the Last Page icon to cycle through the
Pages open for that Device; if they are not open, this will
open them.

Once you have made all your changes, you can download the new Workspace to your MX-1000
remote; see page 8 for details.
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DRAWING BUTTONS

We’ve saved the best part of MX Designer for last: drawing buttons. Designer includes a basic set of
drawing and erasing tools for you to create your own series of buttons, which you can then download
for use on your personalized MX-1000 remote control. Buttons can be thematic in nature, or
randomly designed: it’s up to you. Buttons can be shared with other users
individually as .btn files, or in groups, using the Workspace .mx format.

Covered in this chapter:

•  The Drawing Toolbar

•  How to Draw Buttons

•  How to Edit Buttons

•  How to Replace ButtonsButtonsButtonsButtons

DRAWING TOOLBAR

The tools used to draw and edit buttons are available from a special Draw Toolbar. When you open a
button window as New or as Edit, the Draw Toolbar is available on the right side of the screen. Its
functionality is self-explanatory, with a couple of notes:

•  Two eraser buttons at the top of the toolbar are different “strengths”: the large-
nibbed eraser removes nine pixels at once; the pointy-nibbed eraser erases one
pixel per click.

•  Right-clicking on a pixel acts as a “quick-erase”, with the eraser assuming the shape
of the tool in use.

•  Change the color applied by a tool by clicking one of the four color wells at the
bottom end of the toolbar.
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DRAW BUTTONS

Drawing new buttons from scratch is a simple process in terms of using the software… the rest is up
to your own creative talents. To draw a new button:

44. Click File > New Button. A blank Button Draw
window opens.

45. Click any of the tools in the Draw Toolbar to the
right of the Draw window, and create a new design.

46. When finished, click File > Close Button File to
invoke the Button Save As dialog box.

47. You are offered the following choices:

•  Yes, save as “More buttons”: saves
your work to the More buttons
template for “storage”.

•  Yes, save as “Buttons”: saves your
work to the Buttons template for
immediate use in the program.

•  Yes, save as file (*.btn): saves your
work to disk as a discrete button file
for later use.

•  Name as—Icon name (visible name):
enter a name that will identify the
button on the templates.

•  Name as—Default button name: enter
the same name or a different name to
identify the button when you drag it
into position on a Display Page.

NOTE: The same Button Save As dialog box
opens if you click File > Close Button File.

EDIT BUTTONS

Use the same tools when editing existing buttons, or making changes to new buttons, as you use
when creating new buttons (above). But instead of opening a new Button Draw window, simply
double-click on any button (on either Buttons template).

REPLACE BUTTONS

Replacing a button on a Device Page with another button from the Button templates is a “snap”:

48. Open a page in the Device Tree.
49. Click the Buttons or More buttons tab.

50. Click and drag any button on top of an existing button. When it is properly positioned, by
matching the upper-left corners of the two buttons, the ∅∅∅∅  symbol disappears and a blue
highlight box indicates that you can correctly drop the button.
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9999
TIPS

This chapter includes a number of time-saving tips that you can apply to make programming the
software a little easier.

MISCELLANEOUS

•  Most mouse functions can be accomplished with either right- or left-clicks.

DISPLAY TIPS

•  Program window can be resized by dragging a corner or double-clicking the title bar.

•  Both the Device tree display and the Workspace area can be widened by click-dragging the
pane borders.

•  Mouse can be right- or left-clicked on most objects in the display.

•  Be wary of placing buttons on the screen in locations different than the original ones, as they
might lose the programming.

SERIAL PORT

•  Com 1 seems to work best for the transfer of data. Ensure there are no conflicts; reread the chapter on
Hooking Up the Hardware on page 4.

BUTTONS

•  For now, there is no way to add codes or functions from within the software, unless
preprogrammed codes have been uploaded. It is expected that this will be possible in a future
release.

•  Moving buttons between pages retains the preprogrammed functionality of commands.
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10101010
TROUBLESHOOTING

This chapter covers some of the problems you may encounter with the software, and how to deal
with them. For issues not covered here, please refer to our website at www.hometheatermaster.com.

CRASHES

Program crashes might be caused by the following:

•  Some owners of Dell laptops have reported problems transferring data.

•  Buttons missing from the internal file system; this might happen if you deleted a button manually
from the Button directory.

SERIAL PORT INFO

•  Com 1 seems to work best for the transfer of data. Ensure there are no conflicts; reread the
chapter on Hooking Up the Hardware on page 4.

BUTTONS

•  You cannot add more than the maximum allowable number of buttons (50).

•  If you get the following error message when uploading a Learned Program file:

… it is probably because you have made changes to the command set layout or codes using
the remote itself. It is recommended that, once you have created an .mx file using the software,
further changes to the button layout should only be made using the software.
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You can, however, upload the Learned Functions from the remote back into the command set with
no problems. So, make any code changes you like using the remote, and upload them to the
software to save them with the command set.

DOWNLOAD ISSUES

Occasionally, if a Data download fails, the MX-1000 remote will appear to lose its functionality. The
System Test screen will display, indicating a Program “Fail”. You will not be able to use the remote.
This usually happens as the result of an interrupted download.

It is easy to correct the situation:

51. Start the Download process using Designer.
52. The program tells you to press download on the remote. Hold down the Power key and

Stop key simultaneously on the remote.

53. The Program Down Load screen displays on the MX-1000 remote.
54. A special Download dialog box displays in the Designer software.

55. Click OK to download the Data from Designer. The Default Workspace data will do just fine,
if you have not stored your own Program data.

Downloading proceeds normally. Once complete, your remote is back to normal.

NOTE: You can also adjust the MX 1000’s screen Contrast from this screen, using
the CH keys.

RESETTING THE MX-1000 / GARBLED SCREENS

Sometimes the remote control displays, accessed from the remote’s Setup Menu, appear garbled or
missing text. This situation can generally be resolved by doing a full reset of the remote.

NOTE: A full reset of the remote will delete any information you have taught to the
remote. Buttons you have designed will be replaced with the standard
system buttons.

To completely reset the MX-1000:

56. Push the Reset button completely in (the button is visible at the top of the battery
compartment, on the left side of the exposed plate).

57. Remove the batteries.
58. Again, push the Reset button completely in.

59. Replace the batteries.
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60. You may need to push the Reset button once more.
The remote audibly registers the reset, and you will see a checksum display on the screen.

61. Check that your menu functions are accessible again. If they are not, repeat the process.

62. Should this reset procedure fail, you may have a defective remote control; contact HTM
technical support.


