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CONTACT INFORMATION

Home Theater Master and Universal Remote Control, Inc., are dedi-
cated to putting customer requirements first. With the introduction of the
HTM MX-1000 and the MX Operating Program software, our entire
team has worked diligently to provide one of the most sophisticated
home entertainment accessories available.

We will continue to improve and upgrade the MX Operating Program.
With that in mind, we’d like you to know that we look forward to your
comments and questions. You can contact us via the following:

Universal Remote Control, Inc.
500 Mamaroneck Avenue,
Harrison, NY.  10528

Website: www.hometheatermaster.com

Customer service e-mail: service@urcmx.com

Customer service hours are 9:00 a.m. to 6 p.m. EST, Monday-Friday.

Information contained herein ©2001 Universal Remote Control Inc.

http://www.hometheatremaster.com/
mailto:service@urcmx.com
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1. INTRODUCTION—GENERAL

The MX-1000 Operating Program (MXOP) is a powerful addition to the
MX-1000 preprogrammed and learning remote control. It allows you to
quickly and easily refine the capabilities of your remote by customizing
Device screens, or pages. Using a PC and a serial cable connected to your
remote, you can download new button and page designs to your remote all
at once, as well as upload already-created page definitions for storage and
manipulation.

WHY SOFTWARE?

Why would you want to use the software, when you already know that the
remote itself is quite capable of creating and assigning buttons for all your
Devices? Simple: the software can do so much more, and it can do it faster.
On the other hand, if you don’t feel inclined to create master works of but-
ton design, or you’re not comfortable with PC software, you can bypass the
MXOP altogether and still enjoy a rich, complete experience setting up the
MX-1000 directly from the remote. The choice is yours: however, may we
suggest that the possibilities for design using the MXOP can provide some
pretty interesting results…

Take a look at the figure below, which compares an actual MX-1000 screen
with the MXOP display screen. You can see that the software exactly du-
plicates the remote’s display. This is one of the design details that makes
using the MXOP so simple.

MX-1000 Main Screen MXOP Software Main Screen
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SOFTWARE CANS AND CANT’S

Of course, you still need the remote for some programming functions.
Here’s a basic list of what you can expect the software to do for you.

WHAT THE MXOP SOFTWARE CAN DO

• Change, delete, add, and copy buttons, to a total of 31 designs (each
of which can be used many times on different page displays)

• Add new buttons from a preset library

• Drag-n-drop buttons to new positions

• Change button labels, using two sizes of text at once, if desired

• Design new buttons with built-in drawing tools

• Zoom in to individual-pixel level for exact drawing

• Position buttons precisely with grid and cursor coordinate control

• Upload settings from the MX-1000, which can then be changed

• Save uploaded page formats to disk

• Download new and revised page and button designs to the MX-1000

• Import page and button designs (command sets) from files created by
other users

• Provide speedy operation through extensive use of mouse right-click

WHAT THE SOFTWARE CANNOT DO (YET)

• Copy button or page command-functionality from screen to screen

• Add preprogrammed commands to buttons

• Delete blank or unused pages

• See page 41 for more

QUICK START: USING THE MX PROGRAM RIGHT AWAY

Quick Start is the name of the next chapter: go there now if you want to
begin programming right away. However, we recommend you read Chap-
ter 4, Transferring Files first, so you can be sure to save your prepro-
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grammed MX-1000 settings before attempting to download new ones.
Quick Start describes how to install the software, and how to quickly
change, delete, add , and copy buttons. Detailed programming instructions
are found in Chapter 7.

Other chapters describe, in detail:

• Hooking up the Hardware,  p.17

• Operating Tips, p.47

• Troubleshooting, p.49

MINIMUM REQUIREMENTS

This manual assumes that you are familiar with the Windows Operating
System. You should understand the concept of file management, Serial
Ports, and BIOS adjustment settings.

To function properly, the MX Operating Program requires at least the fol-
lowing:

• PII 133 or better CPU
• Windows 95, 98, 98SE, ME, or NT 4 or better
• 128 MB RAM
• 6 MB hard disk space
• Available Serial Port
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2. QUICK START

This chapter provides a simple overview that you can use to get the MX
Operating Program software up and running right away, and do some but-
ton programming.

NOTE:  You can also design  your own buttons using the
Drawing Tools on the Buttonbar; see Chapter 7,
Designing Screens for details.

Covered in this chapter:

• Installing software

• Working with buttons

Main Program Screen
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INSTALLING SOFTWARE

To install the MX Operating Program:

1. Run the MX100 Design.exe file, and follow the instructions.
2. Following installation, run the program from the Start menu.

NOTE: You can run multiple instances of the software;
however, this is not recommended.

WORKING WITH BUTTONS

This section describes how to quickly:

• Delete buttons
• Change buttons
• Replace buttons
• Copy buttons
• Add buttons
• Edit button labels

Creating buttons is covered in detail in Chapter 7, Designing Screens.

NOTE:  To apply your button changes to the MX-1000, you
must download them to the remote. Prior to doing
so, you may wish to save your existing command set
(a command set consists of all file types used by the
MX-1000). For instructions on doing this, refer to
Chapter 3, Hooking up the Hardware.

To delete a button shape:

1. Click on a Device and page in the Device tree, at the left of the
software display.

2. In the Page Preview window, right-click twice the button you
want to change (not on the text).

3. Click Delete from the pop-out menu; the button deletes.
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4. Click File > Save As from the menu bar, and give your new lay-
out a new file name (the “default.mdl” layout cannot be
changed).

NOTE:  Do NOT use the Delete button on your keyboard.

To change a button shape:

1. Click on a Device and page in the Device tree, at the left of the
software display.

Device Tree, Two Devices Open

2. Click on any .btn name in the Button Menu window to preview
button types. They will appear in the Button Preview window; de-
cide which button you prefer.

3. In the Page Preview window, right-click twice the button you
want to change (not on the text).

4. Click Change from the pop-out
menu. The Select button in the
Button Preview window
becomes a Change button.

Device
tree

Button Menu
Window

Page Preview
Window

Button Preview
Window
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5. Click the Change button. The button you selected in the Page
window assumes the new button look.

6. Click File > Save As from the menu bar, and give your new lay-
out a new file name (the “default.mdl” layout cannot be
changed).

NOTES: 1. Buttons listed in the Button Menu are associated
with preprogrammed commands.
2. Device buttons cannot be deleted; they can be
changed, however.

To replace a button:

Replacing a button is different than Changing a button. When you Change
a button shape, the button keeps its associated command. When you Re-
place a button, any associated command is lost. To regain the command,
refer to Restoring Preprogrammed Commands on page 34.

Generally, a button should only be added in the location of an existing
button (see Chapter 7 for more details).

1. Click on a Device and page in the Device tree, at the left of the
software display.

2. In the Page Preview window, right-click any button twice.
3. Click Delete from the pop-out menu.
4. Click on any .btn name in the Button Menu window to preview

button types. It will appear in the Button Preview window; decide
which button you prefer.

5. Click the Select button.
6. Move the cursor over the Page Preview; you will see an outline of

the new button.

NOTE: Use the Grid button to display two types of grid for
exact button positioning.

7. Click where you want the button to be located; the new button
drops into place.

8. Click File > Save As from the menu bar, and give your new lay-
out a new file name (the “default.mdl” layout cannot be
changed).
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NOTES: 1. Buttons listed in the Button Menu are not associ-
ated with preprogrammed commands.
2. Device buttons can be changed, but not de-
leted.

To copy a button:

A button from any page (within a single Device) can be copied to replace
an existing button (see Chapter 7 for more details).

1. Click on a Device and page in the Device tree, at the left of the
software display.

2. In the Page Preview window, right-click any button twice.
3. Delete the button (see To delete a button shape above).
4. Right-click twice on the button you want to copy.
5. Click Copy.
6. Position the mouse cursor at the upper-left corner of the location

you want to paste the copied button.
7. Left- or right-click; the button is pasted to the Page.
8. Click File > Save As from the menu bar, and give your new lay-

out a new file name (the “default.mdl” layout cannot be
changed).

To create a new button shape:

1. Click Button > Design from the menu bar; the Button Edit win-
dow displays.

2. Draw a new button shape, using the tools in the Drawing area of
the button bar (for details, see Chapter 7, Designing Screens).

3. Click the Save button in the upper-right of the Drawing Window.
4. Once the button is saved, the program will ask Do you want to

register the button?

NOTE:  You can register up to 31 created buttons; see
Chapter 7, Designing Screens for details.

Drawing
Tools
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5. Modify the button after it is registered by clicking on the button
name in the Button Display window, clicking the Select button,
and left- or right-clicking in the Button Drawing window to paste
it. After modifying, click the Save button again.

6. Click File > Save As from the menu bar, and give your new lay-
out a new file name (the “default.mdl” layout cannot be
changed).

To add a button:

Generally, a button should only be added in the location of an existing
button (see Chapter 7 for more details).

1. Click on a Device and page in the Device tree, at the left of the
software display.

2. In the Page Preview window, right-click any button twice.
3. Click on any .btn name in the Button Menu window to preview

button types. They will appear in the Button Preview window; de-
cide which button you prefer.

4. Click the Select button.
5. Move the cursor over the Page Preview; you will see an outline of

the new button.

NOTE: Use the Grid button to display two types of grid for
exact button positioning.

6. Click where you want the button to be located; the new button
drops into place.

7. Click File > Save As from the menu bar, and give your new lay-
out a new file name (the “default.mdl” layout cannot be
changed).

NOTES: 1. Buttons listed in the Button Menu are associated
with preprogrammed commands.
2. Device buttons can be changed, but not de-
leted.

To edit or add button labels:

1. Click on a Device and page in the Device tree, at the left of the
software display.
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2. Click Font from the menu bar, and click either Small or Large;
this will determine the size of the actual typeface being used.

3. In the Page Preview window, right-click any button twice.
4. Click Edit; a cursor appears in the text.
5. Backspace over the existing text, and enter new text.
6. Click File > Save As from the menu bar, and give your new lay-

out a new file name (the “default.mdl” layout cannot be
changed).

7. For more details on the topic of editing text, see Editing Labels
and Text on page 46.

NOTE: Do not use the   button when editing button la-
bels; this command is reserved for adding text to
screen backgrounds. See Editing Labels and Text on
page 46.

NOTE: You can also use the Drawing Tools on the Buttonbar
to draw directly on the Page Preview display. This is
useful if you want to add instructional or other text
that is not for button labels.
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3. HOOKING UP THE HARDWARE

The MX Operating Program can transfer Device files to and from the MX-
1000 remote control.

Covered in this chapter:

• Connecting the serial cable

• Serial Port Settings

Transferring files is accomplished with the special cable provided with the
MX-1000.

One end of the cable is a mini-jack that plugs into your MX-1000; the other
end is an RS-232 serial connector that goes to a PC serial port.

To connect your MX-1000 to your PC:

1. Ensure that you have a spare, active serial port on your PC. You
may have to change a setting in your BIOS.

2. Plug the female serial connector to a serial port on your PC.
3. Plug the mini-jack into the MX-1000’s base.

NOTE:  Prior to downloading any new settings to your re-
mote, it is a good idea to upload your current set-
tings and save them. This way, you will always have
a backup in case an operation fails, especially if you
have already spent some time programming your
remote.

Remote to PC Connector Cable
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To upload and download files, refer to Chapter 4, Transferring Files.

SERIAL PORT SETTINGS

Data transfer via serial ports can sometimes be tricky. To set up the soft-
ware for a serial port on your PC:

1. Click Setting > Serial Port.
2. Click a button to select a known, available serial port. Com 1 is

recommended.

NOTE:  If a particular port is not is in use or not activated,
you will have to do some troubleshootingtroubleshootingtroubleshootingtroubleshooting, either to
set up your BIOS or remove Com port conflicts.

3. Check to ensure that your PC’s port settings conform to the fol-
lowing:

PARAMETER SETTING

Bits per second: 115200
Data bits: 8
Parity: None
Stop bits: 1
Flow control: Xon / Xoff
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4. TRANSFERRING FILES

Before you can transfer files between the MX Operating Program and your
MX-1000 remote control, you must connect the serial cable between your
PC and the remote. Details for this are found in Chapter 3, Hooking up the
Hardware.

You can also import and use command sets created by other users. Refer to
the procedure at the end of this section for details.

Covered in this chapter:

• MXOP File Types

• Uploading/Downloading

• Importing Command Sets

COMMAND SETS: MXOP FILE TYPES

As you may have suspected, there is more than one file-type associated
with programming the MX-1000. As a group, these files are known as a
Command Set. The files in a command set are described as follows:

File type Description

.mdl This is the main Page file, and contains the physical lay-
out of all the buttons for each device. The contents of an
.mdl file are displayed in the DeviceDeviceDeviceDevice tree.

.btn The .btn file holds the description and design  of the
buttons themselves.

button.ini Different buttons can be used for each layout you cre-
ate;  the button.ini file tells the Operating Program
which set.

.ldt The commands learned by your remote are contained in
the .ldt file. They are linked directly to the buttons.

.pdt Any program set you define creates its own .pdt file, it
holds commands associated with pre-programming your
remote with Device codes from the Set-Up Code Table.
This file must accompany the others if you want to ex-
change full command functionality.
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Files in Command Set

All file types are required to properly run both the software and the remote
control.

NOTE:  When uploading/downloading these files, it is im-
portant that they be initially placed in the root di-
rectory of the MX Operating Program.

To upload and download the MXOP files, see below.

UPLOADING

Begin by uploading your current MX-1000 settings to the program. This
will give you a safety backup of your remote’s commands, which you can
always return to if you make a mistake or change your mind.

Two types of file must be uploaded:

• Operating Program files
• Learned Program files

To upload the Operating Program files from your MX-1000:

1. Ensure that you have correctly connected your PC and remote
using the supplied cable; see Chapter 3, Hooking up the Hard-
ware.

2. On your MX-1000, select Program Loading from the System Set-
tings screen. The PC Interface screen displays.

3. From the software menu, click Upload > Operating Program. A
message window will open, confirming your request.

4. Click Upload in the message window. Another message appears
telling you to Please press the Upload button on the LCD screen
of your remote control.

5. Press the Up Load button under Operating Program on the PC
Interface screen. The software takes control and transfers the files
from your remote to the PC; a progress bar displays, indicating
that the transfer is active.

6. The remote plays a tune when the process is complete. The dialog
changes to a Receive OK! Message, and a File Open/Save dialog
displays over the software.
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7. Enter a name for your newly-uploaded .mdl file.

NOTE:  The Receive OK/Cancel dialog remains open until
after you have saved the new file.

8. Click Save to save the .mdl file, and the Creating File dialog
displays.  A progress bar displays.

9. Click Finish when the process is complete.
10. Begin programming your new command set. See Chapter 5,

Software Description for details.

To upload the Learned Program files from your MX-1000:

1. Ensure that you have correctly connected your PC and remote
using the supplied cable; see Chapter 3, Hooking up the Hard-
ware.

2. On your MX-1000, select Program Loading from the System Set-
tings screen. The PC Interface screen displays.

3. From the software menu, click Upload > Learned Program. A
message window will open, confirming your request.

4. Click Upload in the message window. Another message appears
telling you to Please press the Upload button on the LCD screen
of your remote control.

5. Press the Up Load button under Learned Program on the PC In-
terface screen. The software takes control and transfers the files
from your remote to the PC; a progress bar displays, indicating
that the transfer is active.

6. The remote plays a tune when the process is complete. The dialog
changes to a Receive OK! Message, and a File Open/Save dialog
displays over the software.

7. Enter a name for your newly-uploaded .ldt file.

NOTE:  The Receive OK/Cancel dialog remains open until
after you have save the new file.

8. Click Save to save the .ldt file, and the Creating File dialog
displays.  A progress bar displays.

9. Click Finish when the process is complete.

NOTE:  The program will not allow you to overwrite the
Default.ldt file settings.



4. TRANSFERRING FILES

22

DOWNLOADING

Once you have created a new command set for your MX-1000 using the
MX Operating Program, you can easily transfer the files to your remote.
The procedure is basically the opposite of the Upload steps.

Two types of file must be downloaded:

• Operating Program files
• Learned Program files

To download the Operating Program to your MX-1000:

1. Ensure that you have correctly connected your PC and remote
using the supplied cable; see Chapter 3, Hooking up the Hard-
ware.

2. On your MX-1000, select Program Loading from the System Set-
tings screen. The PC Interface screen displays.

3. From the software menu, click Download > Operating Program.
A message window will open, confirming your request with in-
structions on proceeding.

4. Click Operating Program > Download on the PC Interface
Screen of the MX-1000. Do not click Download under the
Learned Program heading on the MX-1000.

5. Click Download in the message window shown in Step 3. The
software takes control and transfers the files from your PC to the
remote; a progress bar displays, indicating that the transfer is ac-
tive.

6. The remote plays a tune when the process is complete. The dialog
changes to a Download succeeded! Message; the remote displays
a test screen, indicating all systems are good.
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7. Click Finish when the process is complete.

To download the Learned Program files to your MX-1000:

1. Ensure that you have correctly connected your PC and remote
using the supplied cable; see Chapter 3, Hooking up the Hard-
ware.

2. On your MX-1000, select Program Loading from the System Set-
tings screen. The PC Interface screen displays.

3. From the software menu, click Download > Learned Program. A
File Open dialog window will open.

4. Click on the name of the .ldt file associated with your .mdl file.
For example, if your main file is named “mine.mdl”, then the
learned program filed is named “mine.ldt”.
A message window will open, confirming your request with in-
structions on proceeding.

5. Click Learned Program > Download on the PC Interface Screen
of the MX-1000. Do not click Download under the Operating
Program heading on the MX-1000.

6. Click Download in the message window shown in Step 4. The
software takes control and transfers the files from your PC to the
remote; a progress bar displays, indicating that the transfer is ac-
tive.

7. The remote plays a tune when the process is complete. The dialog
changes to a Download succeeded! Message; the remote displays
a test screen, indicating all systems are good.

8. Click Finish when the process is complete.
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IMPORTING COMMAND SETS

There is already a growing user-base of MX-1000 owners. With the special
design capability of the MXOP, there are sure to be some interesting com-
mand sets. You can share your own creations with other users, and import
their sets to use with your MX-1000.

To use command sets created by others:

1. Ensure that you have all file types associated with the command
set you want to import: .mdl, button.ini, .ldt, and .pdt.

NOTE:  All files must be located in the root directory of the
folder where the MX Operating Program is installed.

2. Ensure that all buttons (.btn files) associated with the com-
mand set are copied into the Button folder.

3. Click File > Open.
4. Find the .mdl file associated with the set you wish to import, and

open it. The Page Display window will show you the button lay-
out for the Main page.

5. Make any changes you want to the buttons and layout, and save
the file using File > Save, or File > Save As if you don’t want to
overwrite the original files.

6. Download the files to your MX-1000; see the section titled
Downloading on page 22.

7. Begin using your new command set.
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5. SOFTWARE DESCRIPTION

This chapter describes the MX Operating Program software in detail.

Covered in this chapter:

• Software display interface
• Main MXOP software display window
• Menus
• Buttonbar
• Device Tree
• Page Preview Window
• Button windows: Menu and Preview

MAIN MXOP WINDOW

The main elements of the MXOP design window, which can be resized to
suit your needs, consist of the following:

Main MXOP Design Window

Device
tree

Button Menu
Window

Page Preview
Window

Button
Preview
Window

Menu

Buttonbar
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• Menu: Provides key functionality for designing Pages (see page 26).
• Buttonbar: Includes single-click shortcuts for some Menu items; con-

tains all drawing-tool buttons for designing and modifying buttons (see
page 27).

• Device Tree: Lists all Devices associated with the MX-1000 remote,
and the four pages available for each Device, whether they are pro-
grammed or not (See page 29).

• Page Preview window: Displays an accurate representation of each
Device screen on the MX-1000, when selected from the Device tree
(see page 30).

• Button Menu window: Lists all buttons registered to the command set
being edited (see page 31).

• Button Preview window: Displays the shape of any button selected in
the Button Menu above it; labels are not associated with these buttons
(see page 31).

• Button Edit window: The Button Edit window (not shown in figure),
accessible from the Button > Design menu, is described in detail in
Chapter 7, Designing Screens.

Each of these elements is described in detail here.

MENUS

The Menu is pretty straightforward, and comprises the following items:

File:  Each of these commands functions exactly like the same commands
in other Windows programs.

 Open: Opens or imports an .mdl file containing a command
set.

 Close: Closes the current file, but leaves the program open.

 Save: Saves the current file in a directory of your choosing.

 Save As: Allows you to save a file with a different name.

 Exit: Exits the program; prompts you to save your file if you
have not done so.
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Button:  Button menu items

 Design: Opens the Button Design window for drawing and
modifying buttons.

 Register: Saves the button name and design in the button.ini file.

 View: Opens the Button View window.

Font:  Allows you to change the size of button-label text between Small
and Large. Both sizes allow a maximum of 14 characters per label.

Upload: Provides for the transfer of files from the MX-1000 remote to the
MXOP; see Chapter 4, Transferring Files for details.

Download: Provides for the transfer of files from the MXOP to the MX-
1000 remote; see Chapter 4, Transferring Files for details.

Setting: Defines a serial port for use with the Upload/Download function-
ality of the MX Operating Program. To use, see Serial port Settings on
page 18.

Help: At present, there is no online Help file.

• Help > About program displays a Window showing the revision
number of the software.

• Go to website takes you directly to the Home Theater Master
Home page. Use this link when seeking Technical Support.

BUTTONBAR

The MX Operating Program Buttonbar provides a number of menu short-
cuts, and the main drawing tools for designing and manipulating buttons.

MXOP Buttonbar

NOTE: You can also use the Drawing Tools on the Buttonbar
to draw directly on the Page Preview display. This is
useful if you want to add instructional or other text
that is not for button labels.
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Buttonbar buttons are described in the table:

Button Description

Open .mdl and associated files, personal or imported

Save .mdl and associated files

Open button design/edit window

Register new button

View button

Edit text on the Device page; not for editing button labels

Choose between Large and Small sized text. Click once for
Large; click again for Small

Color buttons: click to select a color before using one of the
shape drawing tools

Cursor tool

Drawing pencil: create dots and dotted lines; one click per
dot

Line tool: Hold down to draw lines

Draw empty square or circle (circles draw from center out)

Draw filled boxes or circles (draws from upper left corner)

Eraser tool: Erases one block per click

Zoom tool: Provides close-up view depending on where you
click in the Button Edit window

Grid views: Provides a grid with either large or small quad-
rants, or both, for pinpoint accuracy when placing buttons

Download Operating Program: Saves the open file to disk,
and downloads to your connected MX-1000

Upload: Upload operating files from your MX-1000 to the
MX Operating Program

Download Learned Program: downloads the commands as-
sociated with buttons to your MX-1000
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Button Description

Upload Learned Program: uploads the commands associated
with buttons to your MX-1000

Cursor indices position: In the lower right corner of
the program window. While not a button, it denotes
the location of the tip of the cursor, for pinpoint ac-
curacy when placing drawing objects

DEVICE TREE

The left-most pane in the MX Operating Program window, referred to as
the Device Tree, displays an explorer-like tree of all the Devices available
to the MX-1000. When you start the MXOP the first time, the Device Tree
displays the default.mdl file. After that, the program remembers which
command set file was loaded last time, and displays that information in the
Device Tree.

Device Tree, DVD Page 3 selected
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Using the tree is simple:

• Double-click on any Device name and click on a page to display that
page of the operating system in the Page Preview window;

• Change Device labels on the Main Page; instructions for editing text are
on page 46.

• The Device Tree display can be widened for viewing by click-dragging
the mouse on the right border of the pane.

PAGE PREVIEW WINDOW

The Page Preview window displays the currently selected program screen.
Apart from actually designing buttons, this is where most of the activity
takes place. Here, you can change buttons, change labels, and copy and
move buttons around to suit your own requirements. This is the key feature
of the MX Operating Program, and what makes it so desirable for owners
of the MX-1000 universal remote control.

Here’s what you can do on this screen:

• Right- or left-click on any button, and drag it to a new position, change
it with another button shape, or delete it altogether (when you delete a
button, the label is deleted as well).

• Right- or left-click on any button label, select Edit, and change the label
or delete it altogether.

For detailed procedures covering the creation and placement of buttons,
refer to Chapter 7, Designing Screens. For procedures covering changing,
deleting, add, copying, and renaming buttons, see Chapter 2, Quick Start.

Tuner Page with
Newly Created

Button
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Once you have made all your changes, you can download the new Operat-
ing Program to your MX-1000 remote; see Chapter 4, Transferring Files
for details.

BUTTON WINDOWS

There are two windows dealing specifically with buttons, other than the
Design/Edit window, that are viewable at all times. They are:

• Button Menu window
• Button Preview window

Button Menu window:  The Button Menu window, in the upper right of
the software display, lists all buttons currently registered to the software. To
appear in this list, a button must be registered.

Button Menu and Button Preview Windows

Buttons are added to the software through the registration process, accessed
through the Button menu.

Button Preview window: Once a button is registered, it
can be selected for use by clicking on its name in the list.
This causes it to appear in the Button Preview window
just  beneath the list. Further actions can be taken once a
button is displayed in the Button Preview window.
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You must add newly created buttons using the Register function before
they will be available in the Button Menu window. Exact procedures for
creating, changing and registering buttons are found elsewhere in this man-
ual.

Button Preview and
Button Menu Windows
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6. BUTTONS AND COMMAND CODES

When it comes to designing Pages for the MX-1000 remote control, it’s all
about the buttons. But before you begin designing your own screens, it’s a
good idea to learn how command codes are associated with buttons, and
how you can ensure that you maintain these links during the upload and
download process.

Covered in this chapter:

• Command Codes

• How are codes linked to buttons?

• Button Key Data Table: what is it?

• Registering buttons

• Button Limits

• Maintaining the links

• Macros and Punch Throughs

• Preventing software crashes

• Stamping vs. Selecting when drawing buttons

COMMAND CODES

Here are a few key things to remember when customizing your Pages and
buttons:

1. When you upload and download your settings between  the
MXOP and the MX-1000, the .ldt file maintains the command-
set links you already preprogrammed. In this way, the buttons re-
member the commands associated with them.

NOTE:  Macros and Punch Throughs are not maintained
during the transfer process.

2. However, when you customize your Pages by moving buttons
around, and changing their shape and labels, the new buttons may
lose their commands. This is especially true if you create entire
new Pages of buttons. After you download the new command set
to the MX-1000, these new buttons will have to be programmed.
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3. Commands can not be added using the software.

HOW ARE CODES LINKED TO BUTTONS?

In the command set, it is the .ldt file that maintains the command code
information for each button. When you upload from the MX-1000 to the
software, the learned commands for each button are still linked. (This is not
true for Macros and Punch Through assignations.)

During the transfer process, the preprogrammed codes are uploaded and
stored in the Button Key Data Table. Changing the button locations in
software may cause the preprogrammed functions to stop working; this can
be rectified with the Add command; see next section.

RESTORING PREPROGRAMMED COMMANDS

Right clicking on any button in the Page Preview window provides access
to the Add Button command. Ignore the unusual name for now; what it
really does is provide you with a means of accessing your preprogrammed
button commands.

It works like this:

1. Change your button, replacing it altogether with a new one (pro-
cedure can be found in Chapter 2, Quick Start.

2. Right-click on the new button to open the Button Key Data Table
(BKDT), see example. The Table shows preprogrammed com-
mands for all buttons on all four Pages of the Device selected.

3. Select the command you want.
4. Click OK. The command is linked to the button, and the BKDT

closes.
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Button Key Data Table

You can also use this functionality to add a preprogrammed command to
any button.

REGISTERING BUTTONS

Once you’ve created a new button (see how to do this in Chapter 7,
Designing Screens), it must be registered to the command set. Only then
will it be available for use with the software. Following registration of a
button, its name appears in the Button Menu window.

To register a new button:

1. Create a new button; see Chapter 7, Designing Screens.
2. Click Save in the Button Edit window. The software will prompt

for a filename (you cannot save over an existing registered button
filename).

3. Once saved, the software will ask if
you want to register the button, so
that it can be used to design pages.
Click Yes.

4. The Button Register dialog opens.
Click the name of the button you want to register.
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5. Click the register arrow.
6. Click OK; this registers the button for use with the software.

NOTE: If you receive an error message, it could be because
you have reached the 31-button limit (see Button Limits, be-
low). Try un-registering one or more buttons, and start again.
Also, always check for double-registrations: the program may
have already registered the button.

Button Registry Dialog

Once the button is registered, its name appears in the Button Menu win-
dow, and it is available for use.

BUTTON LIMITS

Even though the design interface allows buttons to be placed anywhere on
the screen, there is a physical limit to the software. Any number of buttons
can be created or added, and they can be placed anywhere on a Page. How-
ever, there are a couple of keys things to keep in mind:

• The maximum number of buttons the software can keep track of is 14
per Device page, for a total of 56 buttons per device. Adding more than
12 to 14 buttons to an individual Page will cause lots of problems. This
is because of the limit for assigned buttons per Device: any more than
56 buttons per device causes problems. You could have more than 14
buttons on a single Page, but you would then need to remove some
buttons from another page to balance the lot.
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• While it may appear that buttons can be added anywhere on a Page,
note the position of the default button command set carefully. With the
exception of adding two buttons to the bottom row of each Page, beside
the Last Page button, the software actually really only remembers the
location of the existing 12 buttons. Placing buttons off this “matrix”
may lead to unusual results. Not that it cannot be done: just watch for
anything out of the ordinary when you download the command set to
the MX-1000.

• The button.ini registry file can maintain a maximum number of 31
buttons per command set. This is true whether the buttons are tiny or
large, and is due to the structure of memory available in the MX-1000.
More than 31 can be added to the registry, but the file will not down-
load properly to the MX-1000. See Chapter 9, Troubleshooting,  for
more information.

• Of the 31 buttons that can be registered, eight are reserved for use by
the software; this means that you can create up to 23 buttons per com-
mand set. The eight reserved buttons are:
• 00:B0

• 01:B1

• 03:B3

• 04:B4

• 05:B5

• 07:CIRCLE1

• 16:Pre-View

• 99:Mark

• It is possible to register files with different filename extensions than
.btn. And they will show up in the Button Menu; however, attempting
to select such a file will cause a runtime error and the program will
crash.
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7. DESIGNING SCREENS

The ability to design screens for your MX-1000 universal remote control
opens a new world of possibilities. It is an unfortunate fact that most re-
mote controls, especially those with preprogrammed commands, often
frustratingly leave out your most important choices for button commands.
Further, remotes with only hard buttons cannot be relabeled, meaning you
have to remember which button does what if you do any special program-
ming. Worse, others in your family, and babysitters who’ve come over to
help out with the kids, often can’t even figure out how to switch your re-
mote into DVD or VCR input mode.

As you know, the MX-1000 comes complete with a huge library of prepro-
grammed commands and button schemes. And using the remote alone, you
can easily re-label the buttons of your choice. So, for example, if you want
to call your TV The Big Screen, you can quickly do just that.

Now, with the MX Operating Program, you can also create and redesign
buttons to match your lifestyle, all at the same time, then save them to a
Command Set file. Then, create a whole different set of Device buttons,
save them to another file, and switch between command sets and buttons
whenever you like. Even better, if you know someone else who owns an
MX-1000 (and shouldn’t everybody?), you can trade command sets easily
via the software.

Covered in this chapter:

• What the software can do

• What the software can NOT do

• Functional limitations associated with programmed commands

• How codes are assigned to buttons

• Buttons

• Mouse functions

• Registering buttons

• Button limit

• Buttons per screen limit

• Memory Limit
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• Designing Buttons

• The drawing tools

• Using cursor keys for exact placement

• The grid

Not covered in this chapter:

Basic techniques for working with buttons are covered in the Chapter titled
Quick Start, on page 10, Working with buttons. These include changing,
deleting, adding, copying, creating, and renaming buttons.

WHAT THE SOFTWARE CAN DO

The MX Operating Program software can simplify your button-design life,
and will let you adapt your remote Device screens to a 100%-satisfaction
level. However, there are some things it won’t do, and you must rely on the
remote itself for these; see the next section in this chapter.

The following tasks can be performed with the software:

• Maintain preprogrammed codes associated with buttons when you up-
load

• Re-label Device buttons from the original 12 to any name at all, with up
to 14 characters, in two type sizes

• Change the size, shape, and label of any button
• Change the size, shape, and label of Macro buttons M1, M2, and M3
• Upload and Download files between your PC and the MX-1000
• Cut, copy, and paste buttons between Pages within a Device
• Create a favorite Device page with buttons from more than one device

showing on single (or multiple) screens
• Create a Main 1 Page for adding your own Device buttons
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WHAT THE SOFTWARE CAN NOT DO

Most of the following tasks can be accomplished using the MX-1000 itself,
but cannot be duplicated using the software.

The following tasks cannot be done with the MXOP:

• Programming codes cannot be entered in the software or attached to
buttons; only those buttons already registered with command function-
ality as part of the upload process maintain codes. This applies to both
preprogrammed and learned codes.

• Macro operations, as with any other commands, cannot be taught
within the software. Macros will stay with buttons that are prepro-
grammed or learned on the remote, but not when downloading.

• Backlight settings, macro timing, beep sound level, date and clock,
touch pad alignment, master Device codes, erasing all buttons and/or
command  codes, resetting buttons to default factory mode (other than
loading the default.mdl file), low battery warning, Punch Through
for volume.

• Cut, copy, or paste buttons between Devices.
• Hard (functional) buttons cannot be programmed with the software.

FUNCTIONAL LIMITATIONS: HOW CODES ARE ASSIGNED

Preprogrammed codes stay with buttons when you upload your command
set (.mdl) files to the MX Operating Program. Also, the registered buttons
that appear in the Button Menu window have no commands associated
with them when you use them for the first time.

For detailed information concerning codes and buttons, refer to Chapter 6,
Buttons and Command Codes.

To add a code to a button created with the MXOP:

1. Download the files to the remote.
2. Assign or teach a command to the new button(s).
3. Upload the new set to the software, and save a new .mdl file. The

button will now have a command associated with it.
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 NOTE:  If you change the label on a Device button, the as-
sociated Device icon in the Device tree will change
to reflect the new label.

DESIGNING BUTTONS

The first thing to note about designing your own buttons is that the pro-
gram will only hold a maximum of 31 button designs. Further, the button
size plays some part in the limitation, 31 very large buttons would not be
accepted by the program. At present there is no real way to tell what the
limitation might be; you will have to experiment.

CREATING A MAIN 1 PAGE

If you have not already done so on the MX-1000 remote control, you can
add a second Main Page. This page mimics the Main page, but also allows
you to change the button designs. Once created, the Main1 page becomes
your default Device page. In this way, you can work around the restrictions
placed on the buttons on the Main Page.

To create a Main1 Page:

1. Ensure that the Main Page is showing in
the software.

2. Right-click on any Device button; the
sub-menu opens.

3. Click Send to MAIN1; a new Main1 Page
is created by the software.

4. Click on the MAIN1 icon in the Device
Tree; the new page displays.

By repeating this procedure for all the Devices you use, you can set up
your own customized default Device Page. Note as well that you have the
ability to assign only the Devices you want to this page; in this way, De-
vices from the Main Page that you do not have in your home system are
ignored.



7. DESIGNING SCREENS

43

BUTTON EDIT WINDOW

Clicking on Button > Edit opens the Button Edit Window.  Here you can
use the drawing tools in the Buttonbar to create your own buttons, or mod-
ify existing buttons.

Button Edit window in Main Display

DRAWING TOOLS

Drawing tool s are accessed from the Buttonbar, highlighted here:

Individual button functionality is described in the table; note that most
drawing tool buttons do not have a corresponding Menu command:

Button Description

Open button design/edit window

Register new button

View button

Edit text on the Device page; not for editing button labels
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Button Description

Choose between Large and Small sized text. Click once for
Large; click again for Small

Color buttons: click to select a color before using one of the
shape drawing tools

Cursor tool

Drawing pencil: create dots and dotted lines; one click per
dot

Line tool: Hold down to draw lines

Draw empty square or circle (circles draw from center out)

Draw filled boxes or circles (draws from upper left corner)

Eraser tool: Erases one block per click

Zoom tool: Provides close-up view depending on where you
click in the Button Edit window

Grid views: Provides a grid with either large or small quad-
rants, or both, for pinpoint accuracy when placing buttons

Cursor indices position: In the lower right corner of
the program window. While not a button, it denotes
the location of the tip of the cursor, for pinpoint ac-
curacy when placing drawing objects

When creating a button, you have three choices:

• You can display a button from the Button Menu window, and click Se-
lect, then paste it into the Edit window;

• You can use the Stamp button in the Edit window to paste a button from
the Button Menu into the Edit window;

• You can draw a button from scratch, using the Buttonbar Drawing
tools.

To create a new button:

1. Click Button > Design; the Button Edit window opens.
2. Click any drawing tool from the button bar.
3. Begin drawing in the Edit window.
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4. To help with exact button placement:

• Use the Grid buttons to help with exact placement

• Use the Cursor indices locator in the lower-right
corner of the MXOP program window

5. When satisfied with your new button, click the Save button in the
Edit window.

6. Save your button with a new name in the Save dialog.
7. The Register dialog will prompt you to register the button.
8. Click Yes; the button

becomes available for use.

A newly-designed
and registered button,
made with a rounded
black box, several cir-
cles, and a few lines.

You can register a button at any time by clicking the Button > Register
menu. Below is an illustration showing all the standard registered button
shapes that are contained in the default.mdl file.

All registered default buttons
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NOTE: You can also use the Drawing Tools on the Buttonbar
to draw directly on the Page Preview display to add
text that is not for button labels.

EDITING LABELS AND TEXT

You’ve seen how to add or change button labels in Chapter 2. The MXOP
editing function has some added power to make your Page screens even
more user-friendly.

Here’s what you can do with the two text tools:

1. Click the S or L button on the Buttonbar to switch between Small
and Large for text size; or click Font > Small/Large from the
Menu.

2. Right-click on any button label to edit the text of the label.

NOTE:  When changing an existing label, back up over, and
delete, any existing characters. This prevents the risk
of merging two different labels, which happens oc-
casionally, throwing the remote out of whack.

3. Add a maximum of 14 characters per label.
4. Click the Text button on the Buttonbar. This Text tool operates differ-

ently than right-clicking on a label. With the Text tool, you can add
text directly to the Page layout, separately from the buttons. This al-
lows you to add extra information, even instructions, to your screens.

5. Add text directly to any Page.

NOTE:  It is possible to edit labels using

the Text button  tool; however, this
will cause problems with the operation
of the Pages following downloads.

Text added to
Page using Text

button tool
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8. TIPS

This chapter includes a number of time-saving tips that you can apply to
make programming the software a little easier.

Miscellaneous

• Most mouse functions can be accomplished with either right- or left-
clicks.

Display Tips

• Program window can be resized by dragging a corner.
• Device tree display can be widened by click-dragging the right border

of the pane.
• Mouse can be right- or left-clicked on most objects in the display.
• Be wary of placing buttons on the screen in locations different than the

original ones, as they might miss the programming.

Serial Port

• Com 1 seems to work best for the transfer of files. Ensure there are no
conflicts; reread Chapter 3.

Buttons

• For now, there is no way to add codes or functions from within the
software, unless preprogrammed codes have been uploaded (see Chap-
ter 6. It is expected that this will be possible in a future release.

• If you cut and paste buttons between pages, you can retain the prepro-
grammed functionality of commands.

• If you lose a preprogrammed command when pasting or moving but-
tons, use the Button Key Data Table via the Add command; see Chap-
ter 6.
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9. TROUBLESHOOTING

This chapter covers some of the problems you may encounter with the
software, and how to deal with them. For issues not covered here, please
refer to our website at www.hometheatermaster.com.

Crashes

Program crashes might be caused by the following:

• Some owners of Dell laptops have reported problems transferring files.
• Too many registered buttons.
• Buttons missing from the button.ini file; this might happen if you de-

leted a button manually from the Button directory.

Serial port info

• Com 1 seems to work best for the transfer of files. Ensure there are no
conflicts; reread Chapter 3.

Buttons

• If you have registered more than the maximum allowable number of
buttons (31), the MX-1000 memory will overflow, causing a program
crash when downloading. To overcome this, un-register buttons until
you can successfully download the command set. Do this by opening
the button.ini file in a text editor, and deleting the filename.

• Text labels seem to be missing or scrambled: This can happen if you
label the buttons using the Text button tool. Always edit button labels
using the right-click Edit function.

• If you are having problems with your buttons not working correctly
after you’ve saved a new .mdl file, try saving it again using a different
name. There seems to be a problem at present with updated files not
completely overwriting existing files.

• If you get the following error message when uploading a Learned Pro-
gram file:

http://www.hometheatermaster.com/
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… it is probably because you have made changes to the command set lay-
out or codes using the remote itself. It is recommended that, once you have
created a .mdl file using the software, further changes to the button layout
should only be made using the software.

You can, however, upload the Learned Functions from the remote back
into the command set with no problems. So, make any code changes you
like using the remote, and upload them to the software to save them with
the command set.

• If two separate buttons seem to be linked by the same command (that
is, you change the command code on one button, and the other changes
too), delete both buttons and replace them. Then re-learn the codes us-
ing the remote.
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